Jump to content
Cesbo Community
  • Announcements

    • RadioSintetica

      News!   12/10/17

      If you have any questions related to installation and purchase, please check our documentation https://cesbo.com/en/astra/docs/ and terms of service https://cesbo.com/en/terms/
      Also, we have an official Telegram chat: https://t.me/cesbo_en  you can ask any questions or share your experience with colleagues Если у вас возникли вопросы по установке и покупке, ознакомьтесь пожалуйста с документацией по адресу https://cesbo.com/ru/astra/docs/ и условиями использования https://cesbo.com/ru/terms/
      Так же, обращаю внимание, что у нас есть официальный Телеграмм чат: https://t.me/cesbo_ru в котором можно задать вопросы - или поделиться своим опытом с коллегами

netmaster

Members
  • Content count

    55
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by netmaster

  1. question about lifetime licenses

    Plan to purchase up to 6 lifetime licenses, and having some questions about the subject 1. No new versions and features - okay, but how about bugfixes? If after few months, with some new and untested [encoders|receivers|streams|channels], become clear, that those errors is not my problem, but particular version of Astra having nasty bug, then my money will be wasted? 2. Does lifetime license still requires Internet access and license servers? If yes, and Cesbo will end it's business after 6 months, closing all license servers, then again, bad luck, and wasted money? 3. This is not directly license related, but rather about protecting future of my investment. Does astra support h265 streams? Astra development has been very slow in last few years, and I do not see point to pay yearly fee for 1-2 minor updates every year. I consider lifetime license, because it is more than 3 times cheaper, that 6 yearly licenses for 5 years.
  2. dvbsub overlay using VAAPI

    actually, you can use software filters with very light or lossless profile, and then reencode it again with proper hardware encoding. It is more complicated, but resource usage and result would be better, than with software encoding only.
  3. dvbsub overlay using VAAPI

    you can’t use software filters and hardware encoding at the same time. Everything must be supported by hardware, and something that complex like subtitle overlay most likely is not. Check the documentation, what filters vaapi supports, and how to use them.
  4. Astra and input from tvheadend

    for some reason, Astra do not take any http input from tvheadend. Astra 5.63, input URL is like http://172.16.16.4:9981/play/stream/service/c59b66ca74ce95448581be8d2dda2164 VLC, AvProxy, ffmpeg, etc. take same stream just fine. Somebody having experience with astra and tvheadend? Astra console: Feb 26 11:00:24: ERROR: [Yle1 i/1] Bitrate:0Kbit/s PES:0 CC:0 Feb 26 11:00:25: INFO: [Yle1 i/1] PAT tsid:3 version:14 Feb 26 11:00:25: INFO: [Yle1 i/1] PAT PMT pid:256 pnr:1025 Feb 26 11:00:25: INFO: [Yle1 i/1] PAT crc32:0x6CD1C265 Feb 26 11:00:25: INFO: [Yle1 i/1] PMT pnr:1025 version:22 Feb 26 11:00:25: INFO: [Yle1 i/1] PCR pid:512 Feb 26 11:00:25: INFO: [Yle1 i/1] VIDEO pid:512 type:0x02 Feb 26 11:00:25: INFO: [Yle1 i/1] VIDEO stream-id:1 Feb 26 11:00:25: INFO: [Yle1 i/1] VIDEO descriptor:0x02031A485F Feb 26 11:00:25: INFO: [Yle1 i/1] VIDEO descriptor:0x02031A4840 Feb 26 11:00:25: INFO: [Yle1 i/1] AUDIO pid:650 type:0x03 Feb 26 11:00:25: INFO: [Yle1 i/1] AUDIO lang:fin Feb 26 11:00:25: INFO: [Yle1 i/1] AUDIO stream-id:11 Feb 26 11:00:25: INFO: [Yle1 i/1] AUDIO descriptor:0x0E03C00255 Feb 26 11:00:25: INFO: [Yle1 i/1] SUB pid:1027 type:0x06 Feb 26 11:00:25: INFO: [Yle1 i/1] SUB subtitling lang:fin Feb 26 11:00:25: INFO: [Yle1 i/1] SUB pid:1050 type:0x06 Feb 26 11:00:25: INFO: [Yle1 i/1] SUB subtitling lang:dut Feb 26 11:00:25: INFO: [Yle1 i/1] TTX pid:5000 type:0x06 Feb 26 11:00:25: INFO: [Yle1 i/1] TTX teletext lang:fin Feb 26 11:00:25: INFO: [Yle1 i/1] PMT crc32:0xC6C1C88B Feb 26 11:00:25: INFO: [Yle1 i/1] SDT tsid:3 version:31 Feb 26 11:00:25: INFO: [Yle1 i/1] SDT pnr:677 Feb 26 11:00:25: INFO: [Yle1 i/1] SDT provider:YLE Feb 26 11:00:25: INFO: [Yle1 i/1] SDT service:YLE TV1 Feb 26 11:00:25: INFO: [Yle1 i/1] SDT crc32:0x288E9DF7 Feb 26 11:00:26: INFO: [Yle1 i/1] Bitrate:2332Kbit/s Feb 26 11:00:26: INFO: [Yle1] Active input #1 Feb 26 11:00:33: ERROR: [Yle1 i/1] response timeout Feb 26 11:00:35: ERROR: [Yle1 i/1] mpegts/sync. buffer empty [size:0Kb time:110ms] Feb 26 11:00:37: ERROR: [Yle1 i/1] Bitrate:0Kbit/s PES:0 CC:0 Feb 26 11:00:37: ERROR: [Yle1] Channel has no active inputs Feb 26 11:00:37: WARNING: [Yle1 o/1] hls. random access indicator not found Feb 26 11:00:38: INFO: [Yle1 i/1] Bitrate:2095Kbit/s Feb 26 11:00:38: INFO: [Yle1] Active input #1 Feb 26 11:00:45: ERROR: [Yle1 i/1] response timeout Feb 26 11:00:47: ERROR: [Yle1 i/1] mpegts/sync. buffer empty [size:0Kb time:111ms] Feb 26 11:00:49: ERROR: [Yle1 i/1] Bitrate:0Kbit/s PES:0 CC:0 Feb 26 11:00:49: ERROR: [Yle1] Channel has no active inputs Feb 26 11:00:50: INFO: [Yle1 i/1] Bitrate:2483Kbit/s Feb 26 11:00:50: INFO: [Yle1] Active input #1 Feb 26 11:00:57: ERROR: [Yle1 i/1] response timeout Feb 26 11:00:59: ERROR: [Yle1 i/1] mpegts/sync. buffer empty [size:0Kb time:111ms] Feb 26 11:01:01: ERROR: [Yle1 i/1] Bitrate:0Kbit/s PES:0 CC:0 Feb 26 11:01:01: ERROR: [Yle1] Channel has no active inputs Feb 26 11:01:02: INFO: [Yle1 i/1] Bitrate:2028Kbit/s Feb 26 11:01:02: INFO: [Yle1] Active input #1 Feb 26 11:01:09: ERROR: [Yle1 i/1] response timeout Feb 26 11:01:11: ERROR: [Yle1 i/1] mpegts/sync. buffer empty [size:0Kb time:110ms] Feb 26 11:01:13: ERROR: [Yle1 i/1] Bitrate:0Kbit/s PES:0 CC:0 Feb 26 11:01:13: ERROR: [Yle1] Channel has no active inputs Feb 26 11:01:14: INFO: [Yle1 i/1] Bitrate:2467Kbit/s Feb 26 11:01:14: INFO: [Yle1] Active input #1 Feb 26 11:01:21: ERROR: [Yle1 i/1] response timeout Feb 26 11:01:23: ERROR: [Yle1 i/1] mpegts/sync. buffer empty [size:0Kb time:110ms] Feb 26 11:01:25: ERROR: [Yle1 i/1] Bitrate:0Kbit/s PES:0 CC:0 Feb 26 11:01:25: ERROR: [Yle1] Channel has no active inputs Feb 26 11:01:26: INFO: [Yle1 i/1] Bitrate:2132Kbit/s Feb 26 11:01:26: INFO: [Yle1] Active input #1 Feb 26 11:01:33: ERROR: [Yle1 i/1] response timeout Feb 26 11:01:35: ERROR: [Yle1 i/1] mpegts/sync. buffer empty [size:0Kb time:110ms] Feb 26 11:01:37: ERROR: [Yle1 i/1] Bitrate:0Kbit/s PES:0 CC:0 Feb 26 11:01:37: ERROR: [Yle1] Channel has no active inputs Feb 26 11:01:38: INFO: [Yle1 i/1] Bitrate:1398Kbit/s Feb 26 11:01:38: INFO: [Yle1] Active input #1 etc. endlessly
  5. Astra and input from tvheadend

    with --debug, and 5.64-test, clicking enable on dashboard, and following happens: Feb 26 12:22:58: DEBUG: [Yle1 i/1] Request: GET /play/stream/service/c59b66ca74ce95448581be8d2dda2164 HTTP/1.1 Host: 172.16.16.4:9981 User-Agent: Astra Feb 26 12:22:58: DEBUG: [Yle1 i/1] Response: HTTP/1.1 200 OK Server: HTS/tvheadend Last-Modified: Mon, 26 Feb 2018 10:22:56 GMT Expires: Mon, 26 Feb 2018 10:23:06 GMT Cache-Control: max-age=10 Connection: Keep-Alive Content-Type: audio/x-mpegurl Content-Length: 159 Feb 26 12:22:58: DEBUG: [Yle1 i/1] Playlist: #EXTM3U #EXTINF:-1,TVHeadend Stream http://172.16.16.4:9981/stream/service/c59b66ca74ce95448581be8d2dda2164?ticket=93A88977D838F523ECE9ABFF54255D28E3AE05B6 Feb 26 12:22:58: DEBUG: [Yle1 i/1] Request: GET /stream/service/c59b66ca74ce95448581be8d2dda2164?ticket=93A88977D838F523ECE9ABFF54255D28E3AE05B6 HTTP/1.1 Host: 172.16.16.4:9981 User-Agent: Astra Feb 26 12:22:58: DEBUG: [Yle1 i/1] Response: HTTP/1.1 200 OK Server: HTS/tvheadend Cache-Control: no-cache Connection: Close Content-Type: video/mp2t Feb 26 12:22:58: ERROR: [Yle1 i/1] mpegts/sync. PCR not found Feb 26 12:22:59: ERROR: [Yle1 i/1] Bitrate:0Kbit/s PES:0 CC:0 Feb 26 12:23:04: ERROR: [Yle1] Channel has no active inputs Feb 26 12:23:08: DEBUG: [Yle1 i/1] Request: GET /play/stream/service/c59b66ca74ce95448581be8d2dda2164 HTTP/1.1 Host: 172.16.16.4:9981 User-Agent: Astra Feb 26 12:23:08: DEBUG: [Yle1 i/1] Response: HTTP/1.1 200 OK Server: HTS/tvheadend Last-Modified: Mon, 26 Feb 2018 10:23:06 GMT Expires: Mon, 26 Feb 2018 10:23:16 GMT Cache-Control: max-age=10 Connection: Keep-Alive Content-Type: audio/x-mpegurl Content-Length: 159 Feb 26 12:23:08: DEBUG: [Yle1 i/1] Playlist: #EXTM3U #EXTINF:-1,TVHeadend Stream http://172.16.16.4:9981/stream/service/c59b66ca74ce95448581be8d2dda2164?ticket=93A88977D838F523ECE9ABFF54255D28E3AE05B6 Feb 26 12:23:08: DEBUG: [Yle1 i/1] Request: GET /stream/service/c59b66ca74ce95448581be8d2dda2164?ticket=93A88977D838F523ECE9ABFF54255D28E3AE05B6 HTTP/1.1 Host: 172.16.16.4:9981 User-Agent: Astra Feb 26 12:23:08: DEBUG: [Yle1 i/1] Response: HTTP/1.1 200 OK Server: HTS/tvheadend Cache-Control: no-cache Connection: Close Content-Type: video/mp2t Feb 26 12:23:08: ERROR: [Yle1 i/1] mpegts/sync. PCR not found and repeating after every few seconds with ffmpeg, no problems root@tv:/home/tv# /root/bin/ffmpeg -y -i http://172.16.16.4:9981/stream/service/c59b66ca74ce95448581be8d2dda2164 -c:v copy -c:a copy -f mpegts ./test ffmpeg version 3.0.1-static http://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2016 the FFmpeg developers built with gcc 5.3.1 (Debian 5.3.1-13) 20160323 configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfribidi --disable-indev=sndio --disable-outdev=sndio --enable-librtmp --enable-libmfx --enable-libzimg --cc=gcc libavutil 55. 17.103 / 55. 17.103 libavcodec 57. 24.102 / 57. 24.102 libavformat 57. 25.100 / 57. 25.100 libavdevice 57. 0.101 / 57. 0.101 libavfilter 6. 31.100 / 6. 31.100 libswscale 4. 0.100 / 4. 0.100 libswresample 2. 0.101 / 2. 0.101 libpostproc 54. 0.100 / 54. 0.100 [mp3 @ 0x4985cc0] Header missing [mp3 @ 0x4985120] Header missing [mpeg2video @ 0x4984580] Invalid frame dimensions 0x0. Last message repeated 10 times Input #0, mpegts, from 'http://172.16.16.4:9981/stream/service/c59b66ca74ce95448581be8d2dda2164': Duration: N/A, start: 23226.787578, bitrate: N/A Program 1025 Metadata: service_name : ?YLE TV1 service_provider: ?YLE Stream #0:0[0x200]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv), 720x576 [SAR 64:45 DAR 16:9], max. 15000 kb/s, 25 fps, 25 tbr, 90k tbn, 50 tbc Stream #0:1[0x28a](eng): Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, stereo, s16p, 224 kb/s Stream #0:2[0x28c](dut): Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, stereo, s16p, 160 kb/s (visual impaired) Stream #0:3[0x403](fin): Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006) Stream #0:4[0x1388](fin): Subtitle: dvb_teletext ([6][0][0][0] / 0x0006) Output #0, mpegts, to './test': Metadata: encoder : Lavf57.25.100 Stream #0:0: Video: mpeg2video ([2][0][0][0] / 0x0002), yuv420p, 720x576 [SAR 64:45 DAR 16:9], q=2-31, max. 15000 kb/s, 25 fps, 25 tbr, 90k tbn, 90k tbc Stream #0:1(eng): Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, stereo, 224 kb/s Stream mapping: Stream #0:0 -> #0:0 (copy) Stream #0:1 -> #0:1 (copy) Press [q] to stop, [?] for help frame= 385 fps= 36 q=-1.0 size= 7285kB time=00:00:16.26 bitrate=3670.0kbits/s speed=1.53x
  6. question about lifetime licenses

    how near? Week, month, year? Can I start with shorter licenses, and if everything run fine, then continue with same servers and lifetime licenses? It seems too paranoid, but after testing several streaming solutions with random errors and shortcomings, I'am rather cautious about spending a lot of money, and just hope, that everything works this time. Sorry.
  7. GeForce GTX 1080 vs NVIDIA GRID M40

    I have 8GB GTX1080, and memory do not worry me that much. Most likely I run out of other resources before GPU memory. I have different problems re-encoding 1080p HD streams to 720p streams. Random artifacts appear in the screen, when source is upscaled SD. I know, this sounds weird, but if stream is native FullHD (news from studio or whatever), then everything works fine for hours, but as soon some old upscaled SD show or film will start, then moving parts get blurry sometimes, although stream parameters do not change. Not often, but after every few minutes. BTW: What version of ffmpeg do you use? I have tried 3.3.6, 3.4.1, and latest from git and 3.3.6 is with less problems in my opinion.
  8. GeForce GTX 1080 vs NVIDIA GRID M40

    okay, that's weird. Usually different version libs can not be mixed, but if you say, that this combination works, then I maybe will try sometime ... Right now I have working patched set of 384.81 and not sure if it is worth to upgrade to newer nvidia drivers. Is it?
  9. GeForce GTX 1080 vs NVIDIA GRID M40

    yes, I did that more than once, but as far I know, patched libnvidia-encode.so.1 must be for the same version like rest of the driver. I mean, patched libnvidia-library for 384.81 (like you provided) can not be used with driver 390.12. Or am I wrong? I was asking, from where you get patched library's for every new nvidia driver?
  10. GeForce GTX 1080 vs NVIDIA GRID M40

    where is that right place?
  11. AvProxy

    that's the problem. Word is full of big expensive projects (starting from Wowza for example), but we need a simple, small, scalable and reliable utility for live http/multicast in and HLS out. If somebody has found such thing, let me know ....
  12. AvProxy

    I will keep eye on your work, and who knows, maybe I am even willing to pay for AvProxy, when it does everything I have dreamed of. :)
  13. AvProxy

    If you not willing to share sources, then full static builds is you only option I think. And if you make static build, then including with all libs. needed for running it. well, that it is not "production ready" yet. Started from that library mess. I do understand, that you intend to keep it simple as possible. But if somebody want to use it in a IPTV environment, then some features is needed, started from PID filtering and so on. Even automatic filtering what drops all unknown or nonstandard streams for HLS, would do. You may say that use ffmpeg or astra then. I do use ffmpeg, but it is not very suitable for 24/7/365 live streams and quits on first few errors and often do not run more than a week without restart, etc. Astra is very good, but I do not like licensing terms of it - pay forever without receiving almost anything, and I prefer not to build my systems on software, what I can not run without constantly asking permission from somebody (license.cesbo.com).
  14. AvProxy

    same result [root@tv29 bin]# LD_LIBRARY_PATH=./ ./AvProxy2-x64 Segmentation fault Another weird thing is, that Apple devices do not play those streams. Both iPad and iPhone with iOS 10.0.2. Just black screen and nothing. If I do make slices from same live source with ffmpeg (no transcoding) and serve them with nginx, then everything works. I think that is another side-effect from that "unknown data" or EPG stream. ffmpeg will automatically discard those. I am searching replacement for my ffmpeg+nginx HLS setup, and AvProxy seems like a perfect candidate, but it is too "beta" for now.
  15. AvProxy

    I am not sure, how to exactly use LD_PRELOAD on this case, but [root@tv29 bin]# LD_PRELOAD=./libc.so.6 ./AvProxy2-x64 Segmentation fault and this is not a good solutions anyway. There is not much point to include only some libs but all the needed ones.
  16. AvProxy

    thank you. tested it and found out, that indeed, c++ libs is half of the problem. On Centos 6 is still ./AvProxy2-x64: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./AvProxy2-x64) ./AvProxy2-x64: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by ./AvProxy2-x64) and that audio glitch I pointed out, is still present. In theory that may be somehow related to my test setup (DELL PE1955 blade and Centos7) and if I wanted to rule this out with one of working servers with Centos6.x, then that libc problem surfaced again. EDIT: tested again with VLC and there is no glitches. Ignore that for now, I will dig a little deeper and try to figure out, what MAG250 do not like there ....
  17. AvProxy

    did send you a PM with live stream URL's. I discovered another glitch. When stream like this has gone through AvProxy, then every time when GET of the next *.ts occurs, after second or so, audio will be muted or stuck for a few milliseconds. Tested with VLC and MAG250. Dont know, is this related to the same problem.
  18. AvProxy

    thanks, please consider static binary option as well ...
  19. AvProxy

    There is no actual errors. None of the other software (astra, VLC, ffmpeg) don't say anything bad about it. If I manually remove this "Stream #0:6: Unknown: none ([5][0][0][0] / 0x0005)" stream with ffmpeg or astra before AvProxy, then errors disappear. I do not have access to the AvProxy source, and do not know what actually causes these lines, but I presume, that it expect a certain type of streams, but receives something weird, like EPG ot teletext, what is too short or start with wrong byte or it simply can't split from right place. If these errors do not hurt and mean anything, then they must be suppressed. about common index.m3u8 ... well, most of us most likely do not want to advertise every possible channel we have ... nginx as a proxy/cache or layer7 filters will help, but anyway ... much easier would be possibility to disable global playlist or make it optional in config.
  20. AvProxy

    neat piece of software indeed, but static binary is absolutely necessary. I did stuck several times to wrong libs, before installed that idiotic Centos7 and got it working. And errors need fixing. I did configure about 40 channels, and it spits out hundreds of such lines per second. Audio and video is fine, but it is hard to simple ignore them. ffprobe shows "Stream #0:6: Unknown: none ([5][0][0][0] / 0x0005)" and I think this is EPG or something which causes these errors. edit: and one question. Is there way to disable index.m3u8 ?
  21. DVB-C input needed

    What is most reliable DVB-C input for computer today? I have whole box of different DVB adapters (USB and PCI-e) but every one of them stop working after some time and few that works, don't have DVB-C.
  22. remap pids

    map = {"video=100","eng=101"} will reamp audio and video pid's, but what about subtitle pid's? How to remap them by language? Thanks...
  23. remap pids

    yep, now it works. Thank you ...
  24. remap pids

    thank you for explanation, but actual probem is, that on 4.3.104 audio PID's wont be remaped on either way.
  25. remap pids

    back to 4.3.35 and it works again with both configuration variants Jul 11 11:37:36: INFO: Starting Astra 4.3.35 Jul 11 11:37:37: INFO: [Test #1] PAT: tsid: 0 Jul 11 11:37:37: INFO: [Test #1] PAT: pid: 52 PMT pnr: 20 Jul 11 11:37:37: INFO: [Test #1] PAT: crc32: 0x9AB14962 Jul 11 11:37:37: INFO: [Test #1] PMT: pnr: 20 Jul 11 11:37:37: INFO: [Test #1] PMT: pid: 100 PCR Jul 11 11:37:37: INFO: [Test #1] VIDEO: pid: 100 type: 0x02 Jul 11 11:37:37: INFO: [Test #1] VIDEO: Stream ID: 1 Jul 11 11:37:37: INFO: [Test #1] AUDIO: pid: 752 type: 0x04 Jul 11 11:37:37: INFO: [Test #1] AUDIO: Stream ID: 2 Jul 11 11:37:37: INFO: [Test #1] AUDIO: Language: hun Jul 11 11:37:37: INFO: [Test #1] AUDIO: pid: 101 type: 0x04 Jul 11 11:37:37: INFO: [Test #1] AUDIO: Stream ID: 3 Jul 11 11:37:37: INFO: [Test #1] AUDIO: Language: eng Jul 11 11:37:37: INFO: [Test #1] AUDIO: pid: 754 type: 0x04 Jul 11 11:37:37: INFO: [Test #1] AUDIO: Stream ID: 4 Jul 11 11:37:37: INFO: [Test #1] AUDIO: Language: ron Jul 11 11:37:37: INFO: [Test #1] AUDIO: pid: 755 type: 0x04 Jul 11 11:37:37: INFO: [Test #1] AUDIO: Stream ID: 6 Jul 11 11:37:37: INFO: [Test #1] AUDIO: Language: pol Jul 11 11:37:37: INFO: [Test #1] AUDIO: pid: 756 type: 0x04 Jul 11 11:37:37: INFO: [Test #1] AUDIO: Stream ID: 7 Jul 11 11:37:37: INFO: [Test #1] AUDIO: Language: rus
×